Thank you for your response. I have done what you have asked and moved to your naming conventions as follows:
function onShippingDisplay(&$order,&$dbrates,&$usable_rates,&$messages)
, also i have changed the way I populate the $usable_rates array as follows:
$usable_rates[$new_method->shipping_id] = $new_method;
I have also red the documentation at
Hikashop Documentation
. However this doesn't resolve my issue, as I still need to display two shipping methods of the same type in my checkout process without having a duplicate shipping method in my "Administrator >> Components >> Hika Shop >> System >> Shipping Methods". While reading the UPS Plugin's code i think i need to use the shippingMethods(&$method) funtion to diplay some kind of dropdown
options, or i could use onShippingSave(&$order,&$methods,&$shipping_id) function when the user selects his shipping method some kind of options are displayed, or I will need to implement warehouses. The reeson i need two visible methods or
options for my shipping plugin is that the api i am calling has an option "Delivery to your door" or "Delivered to the closest Courier's office" and the prices for those options are different. Scince i am developing a plugin and not a single website i can't resolve the issue in any other way such as custom fields or the like.